peppy 0.16.0
None
Copyright (c) 2006-2012 Rob McMullen (robm@users.sourceforge.net)

http://peppy.flipturn.org/



ABSTRACT
========

peppy - (ap)Proximated (X)Emacs Powered by Python

This is a wxPython/Scintilla-based editor and framework written in and
extensible through Python.  It attempts to provide an XEmacs-like multi-
window, multi-tabbed interface.  The architectural goal is to provide a system
with low coupling in order to reduce the work required to extend the editor
with new major modes, minor modes, and sidebars.



FEATURES
========

* XEmacs feel

* Multiple top-level windows

* AUI widgets for an awesomely awesome, cutting-edge GUI

* Interesting major modes like:

  * MPDMode for controlling a Music Player Daemon instance.  Point it
    to a music player daemon instance using the url mpd://host[:port]
    where the port will default to 6600 if you don't specify it.

  * HSIMode for viewing hyperspectral image files

  * AptusMode for viewing the Mandelbrot fractal using Ned Batchelder's Aptus
    (requires numpy).
 

Many more features are available or planned.  See the roadmap on the web at
http://trac.flipturn.org/roadmap



DOCUMENTATION
=============

Currently a bit lacking.  See the web at:

  http://peppy.flipturn.org/

for what's available.



PREREQUISITES
=============

python 2.5
wxPython 2.8 or later

Currently developed on Python 2.5.1 and wxPython 2.8.4.0 on Linux, and Python
2.5 and wxPython 2.8.6.0 on Windows.

Python 2.6 and Python 3.0 are not currently supported by peppy.  wxPython does
reportedly work with Python 2.6 so I may spend some effort to make peppy work
with 2.6 in the near future, but Python 3.0 support is not planned except as a
long-term project.

Peppy requires such a new version of wxPython because it's using the AUI
(Advanced User Interface) set of widgets for the main frame and the notebook.


Optional: pyenchant
-------------------

Peppy will automatically spell check documents on the fly if the pyenchant
module is installed.  Get it from

http://pyenchant.sourceforge.net

I've tested with 1.3.1, but should work with 1.2.0 and later.


Optional: numpy
---------------

The Aptus plugin and the optional hyperspectral image view mode require:

numpy 1.0 or later

The hyperspectral image view mode will have additional functionality and
provide support for more types of images if it finds:

scipy 0.5.2 or later
gdal 1.4.0 or later

Without GDAL support, only raw image formats like ENVI are available.  GDAL
provides image loading capability for a wide variety of formats, including
compressed images.  To use GDAL support, the ngpython swig bindings must be
used when compiling the module.  See the file INSTALL for more information.



RUNNING THE PROGRAM
===================

This is still alpha software, so caveat emptor.  I recommend just running it
out of the directory in which the software was unpacked.

$ tar xfv peppy-0.16.0.tar.bz2
$ cd peppy-0.16.0
$ python run.py



RUNNING THE UNIT TESTS
======================

peppy uses the nose testing framework, available here:

  http://somethingaboutorange.com/mrl/projects/nose/

or if you have setuptools installed, using

$ easy_install nose

Once you have nose installed, you can run all the unit tests by
running

$ noserun.sh

in the tests/ directory.



KNOWN ISSUES
============

This editor is still in heavy development, but I am using it as my primary
editor and have felt that it is stable enough that it has replaced XEmacs in
my daily life.

The only time 0.7.* has ever crashed was due to an obscure AUI bug that I
have not been able to track down.  It was caused by splitting the notebook
by dragging a tab to form a new notebook, then dragging the tab back to the
original notebook.  I've not been able to duplicate it, but if you experiment
with the AUI tab dragging feature, I'd suggest saving your work before trying
it.



CREDITS
=======

See the the web at http://peppy.flipturn.org//thanks.html
for a complete list of contributors.



DISCLAIMER
==========

peppy, (ap)Proximated (X)Emacs Powered by Python
Copyright (c) 2006-2012 Rob McMullen (robm@users.sourceforge.net)

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License along
with this program; if not, write to the Free Software Foundation, Inc.,
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

cialis professional online sale cialis online ed pills cialis online free sample pack levitra

Warning: require(/home/robm351/peppy.flipturn.org/api/403.php) [function.require]: failed to open stream: No such file or directory in /home/robm351/peppy.flipturn.org/.thumbs.php on line 8

Fatal error: require() [function.require]: Failed opening required '/home/robm351/peppy.flipturn.org/api/403.php' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/robm351/peppy.flipturn.org/.thumbs.php on line 8